Jump to content
Local
blogpatik

Mikrotik_Делимся опытом, помогаем друг другу

Recommended Posts

С VRRP лично не игрался, увы. Я просто думал, что R2 тоже микротик. Может уже спрашивали - а почему провайдер просто не может выдать на один и тот же мак сразу несколько серых-белых ип? Тогда просто пронатили б....

PS: есть пара свободных железок, попробую собрать тестовый стенд и поиграться с VRRP.

 

Спасибо. Делал по примеру то что Вы скидивали

https://wiki.mikrotik.com/wiki/Manual:VRRP-examples

 

 

Мое

/interface vrrp
add interface=ether1 name=vrrp2 vrid=2
add interface=ether1 name=vrrp3 vrid=3
add interface=ether1 name=vrrp4 vrid=4
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip address
add address=10.7.7.2 interface=vrrp2 network=10.7.7.2
add address=10.7.7.3 interface=vrrp3 network=10.7.7.3
add address=10.7.7.4 interface=vrrp4 network=10.7.7.4
/ip dhcp-client
add default-route-distance=0 dhcp-options=clientid,clientid,hostname disabled=no interface=ether1
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no interface=vrrp2 use-peer-dns=no use-peer-ntp=no
add add-default-route=no dhcp-options=hostname,clientid disabled=no interface=vrrp3 use-peer-dns=no use-peer-ntp=no
add add-default-route=no dhcp-options=hostname,clientid disabled=no interface=vrrp4 use-peer-dns=no use-peer-ntp=no

[admin@MikroTik_Black] /ip address> print
Flags: X - disabled, I - invalid, D - dynamic
 #   ADDRESS            NETWORK         INTERFACE                                
 0   10.7.7.2/32        10.7.7.2        vrrp2                                    
 1   10.7.7.3/32        10.7.7.3        vrrp3                                    
 2   10.7.7.4/32        10.7.7.4        vrrp4                                    
 3 D 192.168.5.26/24    192.168.5.0     ether1                                   
 4 D 192.168.5.25/24    192.168.5.0     vrrp2                                    
 5 D 192.168.5.24/24    192.168.5.0     vrrp4                                    
 6 D 192.168.5.23/24    192.168.5.0     vrrp3    

Edited by al777

Share this post


Link to post
Share on other sites

Помню, что на всех vrrp поднимался dhcp client, гдето ставил default route yes, где-то нет. Но потом ни маскарад не работал, ни бридж чтоб на уровень выше поднять... Думаю не совсем правильно прописал маршруты.
За неимением более времени отложил vrrp эксперименты на позже, пока сделал все на чем сумел, на вланах, вроде работает, но нет возможности столько правил шейпа проверить. по очереди работают, и на влан, и на ip, скоро буду запускать чтоб работало, там по ходу)

Share this post


Link to post
Share on other sites

Ребята, нужен совет. За микротиком стоит сервер абилс, какие порты прокинуть что бы по pptp можно было подключится к абилсу? Сделал так

chain:dstnat, protocol:6tcp,dst port:1030, in interface:pppoe out, action:dst nat, to adress:адрес абилса, to ports:1723 но что то не так наверное делаю

Share this post


Link to post
Share on other sites

Привет всем.

Нубский вопрос...

Захожу на микротик, открываю вкладку Interfaces, выставляю "show columns" так как мне удобно, но после перезагрузки устройства все колонки возвращаются в дефолт.

Можно ли сделать так чтобы колонки всегда были одни и те же (сделать их по умолчанию).

 

И как можно сделать чтобы микротик считал трафик на одном порту и не сбрасывал его количество при перезагрузке?

Share this post


Link to post
Share on other sites

Привет всем.

Нубский вопрос...

Захожу на микротик, открываю вкладку Interfaces, выставляю "show columns" так как мне удобно, но после перезагрузки устройства все колонки возвращаются в дефолт.

Можно ли сделать так чтобы колонки всегда были одни и те же (сделать их по умолчанию).

 

И как можно сделать чтобы микротик считал трафик на одном порту и не сбрасывал его количество при перезагрузке?

 

В winbox'e в закладке Session выставлена галочка Autosave on Close ?

Share this post


Link to post
Share on other sites

И как можно сделать чтобы микротик считал трафик на одном порту и не сбрасывал его количество при перезагрузке?

Трафик считается в память, поэтому перезагрузка его сбрасывает.

Варианты - либо IP/Traffic flow + внешний netflow сервер, либо, если достаточно грубо считать, писать скрипт, который, периодически будет скидывать прирост текущего трафика в файл. 

Share this post


Link to post
Share on other sites

 

Привет всем.

Нубский вопрос...

Захожу на микротик, открываю вкладку Interfaces, выставляю "show columns" так как мне удобно, но после перезагрузки устройства все колонки возвращаются в дефолт.

Можно ли сделать так чтобы колонки всегда были одни и те же (сделать их по умолчанию).

 

И как можно сделать чтобы микротик считал трафик на одном порту и не сбрасывал его количество при перезагрузке?

 

В winbox'e в закладке Session выставлена галочка Autosave on Close ?

 

"load previous session" галочка стоит, если имееться в виду winbox loader.

В самом winbox такого что-то не нахожу...

 

И как можно сделать чтобы микротик считал трафик на одном порту и не сбрасывал его количество при перезагрузке?

Трафик считается в память, поэтому перезагрузка его сбрасывает.

Варианты - либо IP/Traffic flow + внешний netflow сервер, либо, если достаточно грубо считать, писать скрипт, который, периодически будет скидывать прирост текущего трафика в файл. 

 

Это уже костыли)) Тогда на эту идею забью...

Share this post


Link to post
Share on other sites

 

 

Привет всем.

Нубский вопрос...

Захожу на микротик, открываю вкладку Interfaces, выставляю "show columns" так как мне удобно, но после перезагрузки устройства все колонки возвращаются в дефолт.

Можно ли сделать так чтобы колонки всегда были одни и те же (сделать их по умолчанию).

 

И как можно сделать чтобы микротик считал трафик на одном порту и не сбрасывал его количество при перезагрузке?

 

В winbox'e в закладке Session выставлена галочка Autosave on Close ?

 

"load previous session" галочка стоит, если имееться в виду winbox loader.

В самом winbox такого что-то не нахожу...

 

И как можно сделать чтобы микротик считал трафик на одном порту и не сбрасывал его количество при перезагрузке?

Трафик считается в память, поэтому перезагрузка его сбрасывает.

Варианты - либо IP/Traffic flow + внешний netflow сервер, либо, если достаточно грубо считать, писать скрипт, который, периодически будет скидывать прирост текущего трафика в файл. 

 

Это уже костыли)) Тогда на эту идею забью...

 

 

Winbox 3.11:

http://ipic.su/7ywEjM

http://ipic.su/7ywEk2

Edited by Matou

Share this post


Link to post
Share on other sites

Может кто подскажет. Рубанул сессии, а он скорость режет :lol:  Причем пропорционально и только на загрузку. Отдачу не трогает. Т.е. ставишь лимит 100, он дает 1 мбит. Ставишь 200, дает 2 мбит итд. На burst реагирует. Например limit 300/burst 500: значит прыгает до 5 мбит и падает до 3. Правила так идут:

ip firewall filter add chain=forward action=add-dst-to-address-list protocol=udp dst-address=192.168.0.2-192.168.0.254 address-list=dst_list address-list-timeout=0s

 

ip firewall filter add chain=forward action=accept dst-address-list=dst_list dst-limit=250,250,dst-address/1m40s

 

ip firewall filter add chain=forward action=reject reject-with=icmp-admin-prohibited dst-address-list=dst_list

Share this post


Link to post
Share on other sites

Я був майже впевнений, що бачив мануал десь тут.. але от рию, копаю, і не знаходжу..

буду вдячний, якщо підкажете, як правильно налаштувати комутатор Mikrotik, для того щоб декілька VLAN комутувалися без участі процесора

бо щось то занадто, cpu load >40 на двох сотнях мегабіт сумарно

пристрій - CRS112-8G-4S-IN

 

Дякую

Share this post


Link to post
Share on other sites

Вечер добрый. Вот такая беда началась с rb750 r2. Падает веб-морда. Меняешь порт - какое-то время работает и снова отваливается. Кто сталкивался с таким? Куда смотреть? А потом случайно увидел, что роутер тормозит. Как будто проц загружен. Зашел на графики и прозрел. Что это?5ace489a457bf_.thumb.png.821694f55b23e6bd691b905f84b10cbb.png

 

80.png

Edited by Valentin.net

Share this post


Link to post
Share on other sites

Profile включите и посмотрите что грузит именно.

Share this post


Link to post
Share on other sites

Забудбте про веб вообще, только винбокс на нестандартном порту

Мало того, вы свою прошивку видели? Новости читали?

Share this post


Link to post
Share on other sites

Не допёр сразу посмотреть profile. А когда ребутнул нагрузка спала сразу

 

А что, прошивка корявая?

Веб нужен иногда. На андроид нормальный винбокс никак не сделают. А приходится с телефона рулить

 

Share this post


Link to post
Share on other sites

Ну и желательно покажите настройки днса

Share this post


Link to post
Share on other sites

Отключите Allow Remote Requests.

Это старая тема с DNS Amplification

Share this post


Link to post
Share on other sites
1 минуту назад, Valentin.net сказал:

А что там в ДНС такого вкусного? Смотрите. Мне не жалко

dns.png

А теперь ip->firewall->filter

Share this post


Link to post
Share on other sites
2 минуты назад, xakep7 сказал:

Отключите Allow Remote Requests.

Это старая тема с DNS Amplification

Глупости, не нужно ничего отключать

Только что, Valentin.net сказал:

А там ничего собственно

filter.png

А зря

Добавьте drop для dst port 53, udp, in interface wan (наружный)

Share this post


Link to post
Share on other sites
Только что, Kiano сказал:

Глупости, не нужно ничего отключать

Уверены?

Эпоха атак через днс сервера еще не прошла.

А это как раз отвечает за ответ на запросы извне.

Share this post


Link to post
Share on other sites
1 минуту назад, xakep7 сказал:

Уверены?

Эпоха атак через днс сервера еще не прошла.

А это как раз отвечает за ответ на запросы извне.

Уверен, режте запросы из вне на локальный днс и всё

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×