SoulRoot Опубліковано: February 10, 2015 at 11:57 Опубліковано: February 10, 2015 at 11:57 (відредаговано) Доброго дня. А чи можете трішки поправити UBinstaller? 1. Якщо обрати автоматичне встановлення, то нема можливості обрати тип встановлення ПЗ(BIN чи SRC). 2. Встановлення з SRC можно було б закинути в Screen. 3. Запропонувати після встановленя, запустити мій PostInstaller :-) 4. Долучити до модулів php доповнення openssl. для зручності, в систему також можна додати: 1. htop - непоганий диспечер завдань. 2. mc - no comments. 3. nano - ну це вже таке... за вподобаннями. Вельми вдячний. Відредаговано February 10, 2015 at 11:59 SoulRoot
nightfly Опубліковано: February 10, 2015 at 12:10 Автор Опубліковано: February 10, 2015 at 12:10 1. Якщо обрати автоматичне встановлення, то нема можливості обрати тип встановлення ПЗ(BIN чи SRC). На то він і "з коробкою автомат" аби бай дефолт BIN був. 2. Встановлення з SRC можно було б закинути в Screen. Досвід підказує, що з шансом близьким до 50% на виході вийде щось не зовсім робоче. Тому таки bin для домохазяйок з коробкою автомат 3. Запропонувати після встановленя, запустити мій PostInstaller :-) fetch http://someurl/postinstaller && sh postinstaller 4. Долучити до модулів php доповнення openssl. Оце хотілось би. Власне крім SSL-я там ше треба по хорошому soap, mysqli, та memcached. Також хочеться ще бути впевненим, що будуть зібрані ftp, imap, pdf та json (вони там по волі дефолта порта збираються). На жаль, точно сказати, коли до цього дійдуть руки - важко. Часозатрати на перезборку та повне тестування бінарників під одну платформу, десь біля одного робочого дня. Тобто майже тиждень на 8.4/9.3. Про те, що потрібно після цього, таки добратись ще до підтримки 10.1 а також заставити всіх оновити свої існуючі установки під свіже оточення - вже навіть згадувати не хочеться.
SoulRoot Опубліковано: February 10, 2015 at 12:20 Опубліковано: February 10, 2015 at 12:20 (відредаговано) Я ось зараз намагаюсь знайти php53-openssl-5.3.29.tbz, в мене нема. А воно потрібно, бо інакше не виходить запустити (pkg_add -r php53-openssl видає не ту версію) Знайшов тут, додайте з можливістю вибору під час установки. А я буду розроблювати де що з цим :-) Відредаговано February 10, 2015 at 12:54 SoulRoot
Ruslan_ua Опубліковано: February 10, 2015 at 13:26 Опубліковано: February 10, 2015 at 13:26 (відредаговано) ез нормального багрепорту з способом повторення проблеми - вести мову банально нема про що лог [Tue Feb 10 14:04:23 2015] [error] [client мойадрес] PHP Warning: fclose() expects parameter 1 to be resource, boolean given in /var/www/billing/modules/engine/ api.pm.php on line 25, referer: http://мойадрес/billing/?module=turbosms'>http://мойадрес/billing/?module=turbosms'>http://мойадрес/billing/?module=turbosms'>http://мойадрес/billing/?module=turbosms'>http://мойадрес/billing/?module=turbosms&sending=true'>http://мойадрес/billing/?module=turbosms&sending=true'>http://мойадрес/billing/?module=turbosms&sending=true'>http://мойадрес/billing/?module=turbosms&sending=true [Tue Feb 10 14:04:23 2015] [error] [client мойадрес] PHP Warning: file_put_contents(exports/fulladdresslistcache.dat): failed to open stream: Permission denied in /var/www/billing/api/libs/api.address.php on line 1144, referer: http://мойадрес/billing/?module=turbosms&sending=true [Tue Feb 10 14:04:23 2015] [error] [client мойадрес] PHP Warning: file_put_contents(exports/darkvoid.admin): failed to open stream: Permission denied in /var/ww w/billing/api/libs/api.darkvoid.php on line 175, referer: http://мойадрес/billing/?module=turbosms&sending=true [Tue Feb 10 14:04:25 2015] [error] [client мойадрес] PHP Warning: fopen(./content//pm/admin.dat): failed to open stream: Permission denied in /var/www/billing/m odules/engine/api.pm.php on line 24, referer: http://мойадрес/billing/?module=turbosms [Tue Feb 10 14:04:25 2015] [error] [client мойадрес] PHP Warning: fclose() expects parameter 1 to be resource, boolean given in /var/www/billing/modules/engine/ api.pm.php on line 25, referer: http://мойадрес/billing/?module=turbosms [Tue Feb 10 14:04:25 2015] [error] [client мойадрес] PHP Warning: file_put_contents(exports/fulladdresslistcache.dat): failed to open stream: Permission denied in /var/www/billing/api/libs/api.address.php on line 1144, referer: http://мойадрес/billing/?module=turbosms [Tue Feb 10 14:04:25 2015] [error] [client мойадрес] PHP Warning: mysql_query(): Access denied for user 'www-data'@'localhost' (using password: NO) in /var/www/ billing/api/libs/api.mysql.php on line 262, referer: http://мойадрес/billing/?module=turbosms [Tue Feb 10 14:04:25 2015] [error] [client мойадрес] PHP Warning: mysql_query(): A link to the server could not be established in /var/www/billing/api/libs/api. mysql.php on line 262, referer: http://мойадрес/billing/?module=turbosms Где не прописан или теряется логин/пароль? Відредаговано February 10, 2015 at 13:32 Ruslan_ua
nightfly Опубліковано: February 10, 2015 at 13:43 Автор Опубліковано: February 10, 2015 at 13:43 Где не прописан или теряется логин/пароль? нигде failed to open stream: Permission denied Нормальным же языком сказано - у вас лажа с правами. Как и почему они у вас так расставлены - остается загадкой.
Ruslan_ua Опубліковано: February 10, 2015 at 16:53 Опубліковано: February 10, 2015 at 16:53 (відредаговано) Дякую, шукаю.. і знайшов! chown www-data:www-data -R /var/www/billing Відредаговано February 10, 2015 at 21:53 Ruslan_ua
testinua Опубліковано: February 11, 2015 at 18:35 Опубліковано: February 11, 2015 at 18:35 (відредаговано) BARVIT так, я знаю чому воно так відбувається. Як на мене, в мовних файлах краще використовувати префікси (або еще 101 спосіб) задля запобігання співпадання. А ще краще контролювати те, що проходить через мовний файл. nightfly перевести все на my_sqli - було б гарно :-) Відредаговано February 11, 2015 at 18:38 testinua
nightfly Опубліковано: February 11, 2015 at 18:48 Автор Опубліковано: February 11, 2015 at 18:48 BARVIT так, я знаю чому воно так відбувається. Як на мене, в мовних файлах краще використовувати префікси (або еще 101 спосіб) задля запобігання співпадання. А ще краще контролювати те, що проходить через мовний файл. nightfly перевести все на my_sqli - було б гарно :-) Вперед. Дозволяю.
Samson Опубліковано: February 12, 2015 at 08:05 Опубліковано: February 12, 2015 at 08:05 У меня сейчас версия биллинга 5,6 хочу обновится но как правильно сделать? Прописать в конфигах недостающие строки это понятно, а как быть с запросами ведь сейчас он обновится до 6,3?
l1ght Опубліковано: February 12, 2015 at 08:21 Опубліковано: February 12, 2015 at 08:21 выполнить по порядку все рекомендации к обновлению, начиная с 5.7 и до 6.3, потом спокойной обновится.
nightfly Опубліковано: February 12, 2015 at 08:22 Автор Опубліковано: February 12, 2015 at 08:22 Прописать в конфигах недостающие строки это понятно, а как быть с запросами ведь сейчас он обновится до 6,3? С конфигами вы все правильно понимаете. С запросами - собственно аналогично. Вкатываете все по очереди снизу вверх, и обновляетесь до последнего стабильного релиза.
abonent1000 Опубліковано: February 13, 2015 at 18:16 Опубліковано: February 13, 2015 at 18:16 (відредаговано) После выхода релиза 0.6.3 установка зависает на пункте "Stargazer distro download has been completed". Причем это происходит как в ручном режиме установки, так и в автоматическом. Кстати на версии 0.6.2. установка проходила успешно ОС: FreeBSD 9.3 Відредаговано February 13, 2015 at 18:17 abonent1000
nightfly Опубліковано: February 13, 2015 at 22:19 Автор Опубліковано: February 13, 2015 at 22:19 Она и сейчас проходит успешно. Залипание на сборке старгейзера вполне себе четко описано в faq.
nightfly Опубліковано: February 13, 2015 at 22:23 Автор Опубліковано: February 13, 2015 at 22:23 P.S. я надеюсь это вы таки переставляетесь на другом тазу, а не таким замечательным способом обновление производите.
abonent1000 Опубліковано: February 15, 2015 at 05:41 Опубліковано: February 15, 2015 at 05:41 Она и сейчас проходит успешно. Залипание на сборке старгейзера вполне себе четко описано в faq. Спасибо! Выставил правильные дату и время - всё установилось. P.S. я надеюсь это вы таки переставляетесь на другом тазу, а не таким замечательным способом обновление производите. я на экспериментальном тазике ставлю, т.к. ubilling пока что изучаю (хочу перейти с Трафик Инспектора на Ubilling)
foxtyumen Опубліковано: February 26, 2015 at 05:57 Опубліковано: February 26, 2015 at 05:57 Как сделать так, чтобы работал reset при "-" балансе. Читал, знаю что логика такая и так надо. А если мне очень надо? =)
nightfly Опубліковано: February 26, 2015 at 16:14 Автор Опубліковано: February 26, 2015 at 16:14 А если мне очень надо? =) Вам это не надо
foxtyumen Опубліковано: February 26, 2015 at 18:40 Опубліковано: February 26, 2015 at 18:40 (відредаговано) Очень надо =) У меня сейчас хомячки из за этого сидят на халяву, приходиться выслеживать и прибивать вручную. Не хочется писать внешний костыль к биллингу.. красоту портить =) P.S. Автозаморозка не устраивает по ряду причин Відредаговано February 26, 2015 at 18:40 foxtyumen
nightfly Опубліковано: February 26, 2015 at 18:48 Автор Опубліковано: February 26, 2015 at 18:48 Очень надо =) Вы ошибаетесь. У меня сейчас хомячки из за этого сидят на халяву, приходиться выслеживать и прибивать вручную. Значит проблема в хреновом планировании уровня доступа. Если после деактивации пользователь по дефолту не блокируется - уже наводит на определенные мысли. Не хочется писать внешний костыль к биллингу.. красоту портить =) Принудительно активировать неактивного пользователя, после чего возвращать его как было... звучит несколько шизофренично, не находите? P.S. Автозаморозка не устраивает по ряду причин Вообще не вижу ничего общего с ресетом неактивных пользователей.
foxtyumen Опубліковано: February 26, 2015 at 19:12 Опубліковано: February 26, 2015 at 19:12 Принудительно активировать неактивного пользователя, после чего возвращать его как было... звучит несколько шизофренично, не находите? Скорее это будет выглядеть как SELECT * from `users` WHERE `Passive`='0' AND `Cash`<='".$afCashLimit."' AND `Credit`='0'; а потом их всех $RSH -l $USER $CISCO clear interface virtual-access $Vi Значит проблема в хреновом планировании уровня доступа. Если после деактивации пользователь по дефолту не блокируется - уже наводит на определенные мысли. Кошка сама по себе не может выполнять функцию биллинга, по этому и приходиться вызывать функцию ресета на всех у кого закончился баланс. Так что если он сам не переподключится или ему не помогут, будет сидеть вечно
foxtyumen Опубліковано: February 26, 2015 at 20:57 Опубліковано: February 26, 2015 at 20:57 Решено: FreeMbAllowInet = yes
nightfly Опубліковано: February 26, 2015 at 21:17 Автор Опубліковано: February 26, 2015 at 21:17 (відредаговано) Решено: FreeMbAllowInet = yes Подсказываю - это для пакетных тарифов, с предоплаченным трафиком, родом из конца 90-х - начала 00-х. Принудительное выполнение OnConnect-а - жесть. Кошка сама по себе не может выполнять функцию биллинга, по этому и приходиться вызывать функцию ресета на всех у кого закончился баланс. Не вижу в принципе взаимосвязи понятий "биллинг" и "хреновина терминирующая доступ". Ваша проблема - в отсутствии понимания, того факта, что ресет - ниразу не должен и не может в нормальных условиях, быть выполнен для пользователя который "кончился". Событие реинициализации по самой своей сущности должно происходить таки для реинициализации активного пользователя методом его последовательного отстреливания и последующего поднятия по-новой (надеюсь понятно зачем?). Для пользователя который должен быть потушен, выполняется вполне конкретный OnDisconnect, который одним своим видом символизирует его предназначение. а потом их всех $RSH -l $USER $CISCO clear interface virtual-access $Vi И этому всему место в OnDisconnect. Попытки реализовать логику обратную двум базовым и интуитивно понятным процессам, "пользователя подняло" и "пользователя убило" - огорчает. Відредаговано February 26, 2015 at 21:29 nightfly
l1ght Опубліковано: February 26, 2015 at 22:08 Опубліковано: February 26, 2015 at 22:08 Принудительно активировать неактивного пользователя, после чего возвращать его как было... звучит несколько шизофренично, не находите? Скорее это будет выглядеть как SELECT * from `users` WHERE `Passive`='0' AND `Cash`<='".$afCashLimit."' AND `Credit`='0'; а потом их всех $RSH -l $USER $CISCO clear interface virtual-access $Vi Значит проблема в хреновом планировании уровня доступа. Если после деактивации пользователь по дефолту не блокируется - уже наводит на определенные мысли. Кошка сама по себе не может выполнять функцию биллинга, по этому и приходиться вызывать функцию ресета на всех у кого закончился баланс. Так что если он сам не переподключится или ему не помогут, будет сидеть вечно а шо ви там такого робите на циско? аклі малюєте?
mgo Опубліковано: February 26, 2015 at 22:30 Опубліковано: February 26, 2015 at 22:30 Как сделать так, чтобы работал reset при "-" балансе. Читал, знаю что логика такая и так надо. А если мне очень надо? =) Ви непробували користуватися табличкою №47 в ipfw? сильно допомагає
-VaSaK- Опубліковано: March 1, 2015 at 09:58 Опубліковано: March 1, 2015 at 09:58 (відредаговано) Всіх з Весною Вже писав, але тут буде доречніше. Стосовно кнопкі, яка б видаляла успіші використання UHW. Така кнопка наприклад як в "Спроби перебору", ну і в інших місцях вона є. Чі планується в наступних релізах? Ще такє ото, бендвиш (bandwidthd) малює графічки - все суперово, але чі можна замість IP показувати Імена з біллінгу? Дякую розробникам. Це шедевр хлопці! А щє крутяцькій відос ото як іконкі бігають і модулі клепають! Чітав тему, де шось криво казали про Ubilling, Найт показав відос, я довго ржав. Молодці хлопаки! Відредаговано March 1, 2015 at 10:29 -VaSaK-
Рекомендованные сообщения